c700 .vst export issue
BotB Academy n00b s0z
 
 
157586
Level 0 n00b
The Diad
 
 
post #157586 :: 2022.06.20 7:55am
Hello,

I'm looking for help on an export issue I am experiencing with the c700 .vst plugin. In short, when I export to .spc, the track loses the first 1-2 seconds or so. This issue does *not* happen when exporting to .smc--it seems to work fine there.

I don't think this is a memory issue because I'm well under the cap, and I can recreate the same problem with a new file. The DAW I am using is FL Studio.

Any suggestions?
 
 
157587
Level 23 Pedagogist
ViLXDRYAD
 
 
 
post #157587 :: 2022.06.20 8:33am
does a spc full memory dump from a emulator snes apu memory while the song plays, saved as is as an spc, works well instead?
 
 
157590
Level 29 Chipist
damifortune
 
 
 
post #157590 :: 2022.06.20 10:58am :: edit 2022.06.20 6:33pm
if you have the start point set where you want it (probably 0.000, which is default) and this is happening, i would try to fix it first by shifting the whole thing forward by a second or two, while leaving the start point the same.

even if your song is sequenced in only one pattern, you could just place it into the Playlist view starting on bar 2, so bar 1 was only silence. or if you were using Playlist view already you could just select everything and drag it forward in time. switch to "song" mode instead of "pattern" mode to the left of the playback controls

depending on whatever's going wrong, you might or might not end up with some actual silence before your track begins? and that may or may not be acceptable, but it's worth testing regardless i think

additionally, if you happen to be using the "c700 microtunable" fork, it does have a known bug that causes note startup problems like what you're describing. i've never seen it in the main VST, but it sounds so similar that i should mention it.

the fix for that has been to add one or more "dummy notes" before the song begins, sort of as a way to initialize the song. they get eaten up and don't play, but then your song does play. don't mess with the start time position here either; but if your song loops, make sure you set the loop point after the dummy notes

c700 microtunable doesn't have that problem with .smc either, only .spc; definitely could be a similar issue, so you could also test placing some notes before your song begins, also easiest done in the Playlist editor
 
 
157607
Level 0 n00b
The Diad
 
 
post #157607 :: 2022.06.21 7:37am
@ViLXDRYAD: I tried that, but I must not be doing it correctly. The file that I get when I try to rip the .SPC from the .SMC is not the song. I will try to learn some more about ripping tracks to see if I can figure out what I am doing wrong there.

@damifortune: Interestingly, when I shift the start of the first pattern backward by a second or two (but leave the start point in c700 at 0.00), the plugin seems to ignore the start point and I get the same effect--that is, the exported .spc file starts at the beginning of the first pattern and ignores the leading silence, but with the first couple notes missing.

Even more confusing, I tried adding in a dummy note at the start and when I exported the .SPC file, it still jumped straight to the first "real" pattern of the first instrument, but skipped the same few notes/seconds 😵. I added a 10 second gap of silence that the plugin ignored when exporting.
 
 
157626
Level 23 Pedagogist
ViLXDRYAD
 
 
 
post #157626 :: 2022.06.21 10:43pm
i thought the whole snes apu memory was a track player+track data, and spc file data itself, while it plays; of course, the main cpu may overwrite the snes apu memory on the fly; this method of ripping could work if the spc remains unmodified by main cpu while playing a track :3
 
 
157633
Level 29 Chipist
damifortune
 
 
 
post #157633 :: 2022.06.22 6:37am
re: adding dummy notes, you could also try adding multiple dummies, or even a dummy bar before the song? 🤔

this sounds pretty strange though! the results of your testing don't make a ton of sense lol. i'd hate to think there were something weird with your sequence, but probably the next things i'd try would be:

1) make micro-adjustments to some of the notes in the area that keeps failing, like moving a couple things around by the smallest grid unit ("none"). does it behave the same if you tweak note placement right where the issue occurs?

2) try duplicating the whole thing, or at least the whole section that's turning into silence? this way you could see if your notes play on the second pass.

this feels like a pretty strange glitch, so i'm mostly trying to see if we can find a way around it, heh. if you want to share the .flp i could take a look at that too, but this is about the extent of my ideas so far 😅
 
 
157646
Level 0 n00b
The Diad
 
 
post #157646 :: 2022.06.22 12:07pm
@damifortune: I'm pretty certain I must have done something to cause this issue. I just wish I could figure out what it was. I suspect it's something obvious I am just overlooking.

1) I tried to slightly delay the first notes to no avail. I used the microadjusting feature in FL studio with the mouse wheel to nudge them back slightly.

2) If I duplicate the pattern that is experiencing the silence it plays normally the second time through--this is also true if it loops with the loop point.

Here is are two .flps, both experiencing the issue: https://file.io/zx45Uo4hsEzP
 
 
157648
Level 29 Chipist
damifortune
 
 
 
post #157648 :: 2022.06.22 1:11pm :: edit 2022.07.29 3:21pm
very interesting... though i definitely hear the missing note problems in both your included .spc files, my attempts at exporting these two projects as .spc were actually successful!

(edit 7/29: i'm removing these files but let me know if you didn't grab them before and i can reupload them somewhere)

https://www.dropbox.com/s/5lp0yl8j19khd2t/SPC%20Test.spc?dl=0
(i made it start immediately and loop properly by setting those both to 2.000)
https://www.dropbox.com/s/reyln2theiux7cb/test2.spc?dl=0
(no modifications whatsoever to the project)

one thing i will say is i'm not using the most current version of c700, so it is worth checking if this issue happens if you downgrade. (or upgrade??) i could probably upload mine if needed

nothing seems amiss about the way you set up the project. i wish i knew enough to diagnose your example .spc files, but that's a little beyond my paygrade. i hope switching versions fixes it even if it doesn't provide an answer :S
 
 

LOGIN or REGISTER to add your own comments!