C700 SPC export advice
BotB Academy n00b s0z
 
 
151035
Level 7 Chipist
grabble
 
 
post #151035 :: 2022.01.17 11:24am
Hi all, I'm trying to work through making an SNES track for my first submission into a major and I keep running into an issue where C700 exports complete silence. I can export just fine up to a certain point in the song and it will render as expected, but if I go a measure or two more the resulting file is completely silent. I've tried:
- Removing any pitch bend or modulation data
- Removing all samples except a sine wave (reduced memory usage test)
- Removing any custom samples from the instruments
- Reducing the amount of midi notes in the song
- Reducing the number of tracks used to 6 (instead of 8)

I'm using Ableton Live + C700 in "accurate" mode and the song is about 3 mins or so, it's not a melodically dense song really, so I am assuming there is some other n00b thing I am doing wrong and running afoul of the 64k limit.

Meantime I'm going to work with SNES GSS and check my work early & often, but I'd also like to get this DAW-based workflow ironed out to have it as an option.

Thanks in advance for your help!

 
 
151103
Level 16 Pixelist
kilowatt64
 
 
post #151103 :: 2022.01.19 8:10am
Hmm, unfortunately I'm probably no help here, I've only tried using it OpenMPT, Reaper, and FL studio, but I would be surprised if it had anything to do with Ableton in particular. I am no expert by any means here, though.

It sounds like you've probably already looked around for help, but in case it's helpful throwing this out:
https://battleofthebits.org/lyceum/View/C700+VST/ <lyceum article has some stuff around the "RAM usage" section that has some troubleshooting tips

http://picopicose.com/how_to_use_the_c700_eng.html << documentation is pretty minimal but also lists a few troubleshooting items.
 
 
151138
Level 7 Chipist
grabble
 
 
post #151138 :: 2022.01.20 11:54am
Thanks for the suggestions!

I had gone over both of those, but didn't see anything about completely silent exports, only exports that hang when memory ran out. So I'm not sure if what I'm running into is a different issue, or different manifestation of the same issue.

But this is a good prompt, I'm going to read them again in case I missed something.

Thanks!
 
 
151175
Level 16 Pixelist
kilowatt64
 
 
post #151175 :: 2022.01.22 6:20am
You can always try instead transcribing your track as a .it, and using SNESmod to convert it as long as it sits below the size limit. Alternatively, you can try reaching out on Discord /IRC and seeing if someone out there uses Ableton with C700 that could take a look at your file, people are often pretty helpful on there.
 
 
151198
Level 28 Chipist
damifortune
 
 
 
post #151198 :: 2022.01.23 10:06am
not sure yet what the answer is here, but have you tried making a new project file with a fresh instance of the vst? it sounds like you've tested pretty thoroughly for memory issues, and indeed i've not encountered "silence" as the result of a memory issue

i'd also recommend making sure the record start point, loop point, and end point are all properly set, but if you've been following instructions you probably don't have an issue with that - just something to double check.

is there anything significant about the timestamp? some weird event data right there, lots of notes, anything? does it line up on a beat?
 
 

LOGIN or REGISTER to add your own comments!